apt sources.list for old versions of Ubuntu

Discontinued versions of Ubuntu are mirrored under http://old-releases.ubuntu.com/ubuntu/, which can be used to setup apt’s sources.list.

For example, for Gutsy (7.10), sources.list would look like:

deb http://old-releases.ubuntu.com/ubuntu/ gutsy main restricted
deb http://old-releases.ubuntu.com/ubuntu/ gutsy-updates main restricted
deb http://old-releases.ubuntu.com/ubuntu/ gutsy universe
deb http://old-releases.ubuntu.com/ubuntu/ gutsy-updates universe
deb http://old-releases.ubuntu.com/ubuntu/ gutsy multiverse
deb http://old-releases.ubuntu.com/ubuntu/ gutsy-updates multiverse
deb http://old-releases.ubuntu.com/ubuntu/ gutsy-security main restricted
deb http://old-releases.ubuntu.com/ubuntu/ gutsy-security universe
deb http://old-releases.ubuntu.com/ubuntu/ gutsy-security multiverse

Thanks to Marty, JohnF, and others on the SLUG list.

Update August/2012

You can also use http://archive.ubuntu.com/ubuntu/ and country specific repos like http://au.archive.ubuntu.com/ubuntu/

Tags:


Share This


 


13 Responses to apt sources.list for old versions of Ubuntu

  1. Worked like a charm. Thanks for posting it.

  2. thanks.

    back to work on 7.10

  3. Thanks a lot, I had to look hard for this info… No info were provided on the ubuntu official web site…

  4. Is it known whether this works for Ubuntu 9.04 as well?

  5. Works like a charm for my warty (4.10) release.
    Yipeekayee :D

  6. [...] O Repositorio peuei Aqui [...]

  7. Trandafir Petronius

    Still works! Thank you!

  8. thanks aloooooooooooooooooot

Leave a Reply

Your email address will not be published. Required fields are marked *

*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>